Back to top

Warmshowers Android app: could not retrieve host information. credentials and check your internet connection ?

Warmshowers Forums Disabled

Dear Warmshowers Community, we know this is a time of concern for everyone around the globe due to the COVID-19 pandemic.  In an effort to streamline communication and better address the current needs of our community in a timely manner, we are temporarily disabling the forums and directing everyone to the Warmshowers Facebook Group. This will allow the Warmshowers Community a centralized place for comments, questions, and concerns related to touring and hosting. As always, we ask that you follow our community guidelines when posting.

Facebook Group: https://www.facebook.com/groups/Warmshowers.org/

Please note: For technical questions see our FAQ's to address your question or use the Contact Us form for technical support ONLY.  We will not be providing any information on travel or hosting requests through the Contact Us form.

8 posts / 0 new
Última mensagem
Membro WS Foto de Membro WS
Warmshowers Android app: could not retrieve host information. credentials and check your internet connection ?

Hello, excuse me for my bad English. I have a problem forsearch with the application on my samsung GT-19295 S4 with android 4.2.2. when I want to search I receive this message "could not retrieve host information. credentials and check your internet connection"
I tried to uninstall and dellete all information cached and then to install but for now it does not change anything.
my internet connection is active and my username and login too. you have any solution?
Thanks

Membro WS Foto de @wsadmin@
I don't think I've heard of

I don't think I've heard of that problem. I guess you've probably done all the things that should be done. It looks like the exact message was "Could not retrieve host information. Check your credentials and internet connection."

* Make sure you have the latest version
* If this is a starred host (saved locally) try deleting it. That will make it load from the site.
* Try logging in to the android app with a different account (it's ok to create a test account on warmshowers if you delete it right away).

It looks to me (looking at the code) that this happens when the app loads a host *either* from local storage or from the site. If the problem is loading locally then the message is quite deceptive, of course.

If you can't figure it out, please
1. Let us know what user you're having trouble with. You can post a link to the user account here.
2. File a detailed bug on the developer's issue queue, https://github.com/warmshowers/wsandroid/issues - requires a free github account.

Thanks,
-Randy
Warmshowers.org webmaster

Unregistered Foto de anon_user
I have the same problem as

I have the same problem as the original poster, I think. I can log in and see the map, and see details about hosts. But, while still logged in, if I try to search for a city, I get "Could not retrieve host information. Check your credentials and internet connection." I'm using Warmshowers version 1.3.4, the latest per Google Play. I tried restarting my phone. I've tried using wi-fi and 3G. My phone uses Android 2.3.4.

Membro WS Foto de @wsadmin@
Please try the things suggested above

The most common cause of this is you're logged out (and don't know it). So please follow the suggestions above, most importantly logging out and logging in again (on the mobile app).

And then go ahead and completely uninstall and reinstall.

Thanks,
-Randy

Unregistered Foto de anon_user
No improvement

I tried uninstalling and reinstalling. No change in behavior; still when I try to search for any city, I get "Could not retrieve host information. Check your credentials and internet connection." I can log in just fine, scroll anywhere on the map and read details about any number of hosts, so I'm sure I'm logged in.
Also, you mentioned logging out. I don't see any place to log out. If I hit the Menu button, I see accounts, and there is a place to enter username and password to log in, but no log out other than closing the application.
Thanks!

Membro WS Foto de @wsadmin@
"Account", not log out

I updated your bug report (thanks) on https://github.com/warmshowers/wsandroid/issues/78

I guess there's no "Log out", as you say, just an "Account" option on the menu where you can re-login.

If you're using your email address, consider using your username, or vice versa. Please try (as suggested over there) using a different network provider, use wifi if you're just using your phone.

Please followup over there, so the developer gets the feedback.

Membro WS Foto de Membro WS
I have the same problem, too

I'm getting the "Could not retrieve host information. Check your credentials and internet connection" message, too.

I'm logged in and I can see starred host info (I only have 2) and I can view a map of an area with all the hosts marked on the map, but no matter what city I enter in the search box I get the message above. I have no problem with my Warmshowers account when I access it through the web browser on the same device.

My smartphone is a Samsung Galaxy S3 GT-I9300, Android version 4.3.

Membro WS Foto de Membro WS
Hi! There was an issue with

Hi!

There was an issue with the text-based search in the previous version which caused the "could not retrieve host information errors". It should be fixed in the latest version (1.3.5), please update to that.

As a bonus the text search is now a lot faster!

cheers
Johannes